Seit Confixx, nun einige Fehler im Forum.

  • Hi,


    bin grad am neuaufbau meines Servers und Forum, nun wollte ich meine Sicherung öffnen, da kommen nun solche Fehler zum Vorschein:


    Warning: fopen(cts_flooder/.time) [function.fopen]: failed to open stream: Permission denied in /var/www/web1/html/test/acp/lib/ct_funktion.inc.php on line 801


    Warning: Cron file access error! Check permissions to write. in /var/www/web1/html/test/acp/lib/ct_funktion.inc.php on line 802


    Die Zeilen 801 und 802 sind diese hier:


    if(!($f = fopen($path,"a+"))){
    trigger_error(E_CRON_FILE,E_USER_WARNING);


    Fehlt mir evtl. eine Funktion in der php.ini?


    Noch weitere Fehler entdeckt: :( Im Hauptforum.. Ahso alles läuft auf mod_php.


    Warning: unlink(smilieupload/morgen002.gif) [function.unlink]: Permission denied in /var/www/web1/html/acp/smilie.php on line 366


    Kann auch ein Link zur phpinfo senden, wenn erwünscht.

  • Permissions denied heißt entweder kann in die Datei/Ordner geschrieben werden.


    Also mal den chmod der Datei/Ordner prüfen bzw. ob das Script überhaupt in den Ordner schreiben kann (Open basedir)

  • Schreibrechte sind natürklich gesetzt, wie setzt ich aber open basedir hier rein:


    <Directory "/var/www/web1/html">
    #Options setzen
    AllowOverride Options Indexes AuthConfig Limit FileInfo


    #Falls die Options der .htaccess nicht gelesen werden
    Options +FollowSymLinks +SymLinksIfOwnerMatch +Includes
    Options +Indexes
    <IfModule mod_access.c>
    Allow from all
    </IfModule>
    <IfModule mod_authz_host.c>
    Allow from all
    </IfModule>
    php_admin_flag engine on
    </Directory>


    <VirtualHost 217.172.179.215:80>
    ServerName spiele-und-musik.eu
    ServerAlias www.spiele-und-musik.eu web1.chicago300.server4you.de
    DocumentRoot /var/www/web1/html
    SuexecUserGroup web1 web1
    ScriptAlias /cgi-bin/ /var/www/web1/html/cgi-bin/
    php_admin_value open_basedir /var/www/web1/html/:/var/www/web1/phptmp/:/var/www/web1/files/:/var/www/web1/atd/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/web1/phptmp/
    php_admin_value max_execution_time 240
    php_admin_value memory_limit 512M
    php_admin_value upload_max_filesize 128M
    php_admin_flag safe_mode Off
    </VirtualHost>


    In der php.ini kann ich ja leider keine änderungen machen, werden ja nicht Berücksichtigt. :(

  • Kann denn keiner Helfen? Kann nicht mal mehr Ct Security installieren, da fliegen mir gleich Errors um die Ohren. :(


    Das atd Verzeichniss das im open_basedir angegeben ist, kann ich via FTP nicht mal öffnen. Da stimmt denke ich mal ne Menge nicht. :(

  • Kann mir denn keiner weiter Helfen?


    Habe nun auch tmp Probleme. :( smarty will tmp im root benutzen.


    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/tmp/%%8E^8EB^8EBF00C3%%info.tpl.php) is not within the allowed path(s): (/var/www/web1/html/:/var/www/web1/phptmp/:/var/www/web1/files/:/var/www/web1/atd/) in /var/www/web1/html/go/vcl/smarty/libs/Smarty.class.php on line 1379


    Fatal error: Smarty error: the $compile_dir '/tmp' does not exist, or is not a directory. in /var/www/web1/html/go/vcl/smarty/libs/Smarty.class.php on line 1092


    Mit diesen Rechte Problemen komme ich nicht voran. :( Teamspeak 3 Web Interface benutzt auch smarty, da habe ich das selbe Problem. :(


    Die anderen fopen Probleme konnte ich beheben. Schreibrechte.

  • Hallo,


    nun der Fehler ist immer noch der selbe -->open_basedir restriction in effect.


    Du mußt den open_basedir Pfad erweitern, damit auf /tmp/ zugegriffen werden kann. Was ich noch von confixx so in Erinnerung habe, kann man das in confix einstellen.


    Du kannst mir auch den confix Adminzugang zusenden, dann stelle ich das ein.


    Micha

  • Hi,


    bekomme ich noch keine Abbo Emails hier. :(


    ich mußte tmp in der web1.conf hinzufügen /etc/apache2/confixx_vhosts


    Über Confixx was einstellen Funktioniert nicht, wird nicht übernommen. Warum weiß ich patu nicht, der mist wurde wohl komplett falsch installiert. :( Backup geht nicht, Cronjobs auch nicht. Nix geht. Subdomain anlegen geht auch nicht. :(


    der tmp Fehler ist nun weh, aber nun geht Filebase Datenbank nicht richtig. Beim Files editieren, zeigt der mir die bereits hochgeladeten Dateien nicht an, damit ich die löschen kann. :(


    Ich werde echt noch irre. Kenne mich zuwenig damit aus. Confixx habe ich machen lassen, nun der hatte wohl zuwenig Ahnung davon.


    Ich brauche echt Dringend Hilfe.


    Sag mir mal welche Daten du brauchst, sende sie dir dann per PN. Müßte wohl doch Plesk drauf machen, nur damit kenne ich mich auch nicht aus. :(

  • Hallo,


    egal ob Du Plesk oder confixx hast, Änderungen an den Webs müssen in diesen Anwendungen ausgeführt werden. Alle anderen Änderungen die nicht in Plesk oder confixx gemacht werden, werden dann durch diese überschrieben.


    Du bist doch bei server4you, welches Paket/ Server hast Du da?


    Micha

  • Naja ich jedoch habe nur einen Dual Core. Aber sonst gehts so. :)


    Naja hatte damals gehört, das Plesk wohl viel ressourcen frißt. Daher hatte ich immer was anderes, jedoch überall Probleme gehabt. Wenn Plesk doch eher zu Empfehlen ist, kann ich das von S4Y drauf machen lassen.


    Aber bräuchte dann unbedingt Hilfe, zwecks Einstellung dann für meine Domain, was php.ini halt angeht.

  • Confixx ist bei S4Y nicht mit Dabei.


    Habe für Confixx eine alte Lizenz Datei hier, die ich mal vom damaligen Serveranbieter hatte.


    Extra gekauft habe ich nichts.

  • Alles klar.


    Um jetzt nicht zeitraubende Fehlersuch in Deiner Installation zu betreiben....würde ich Dir empfehlen Plesk zu nutzen.


    Alternativ geht auch wieder confixx, aber auch nur über eine Neuinstallation und ohne Grund bietet s4you da nicht mehr confixx an.


    Die Entscheidung mußt Du treffen, die Domain ist aber auf alle Fälle dann erst mal nicht erreichbar.


    PS: mit Plesk habe ich keine schlechten Erfahrungen


    PPS: übrigens mit der Abbo Mail habe ich gerade probiert..funktioniert. Du mußt das Thema abbonieren und in Deinen persönlichen Einstellungen das Versenden der E-Mail freigeben.

  • Hi,


    mache auch grad ein Backup vom Forum. :)


    Habe den Large X5 Server mal bestellt. Den X2 Kündige ich dann danach. Domain werde ich dann übertragen.


    Mehr Leistung für den selben Preis. Kann ich mich dann an dich wenden, wenn es soweit ist?


    Jo email Benachrichtigung geht wieder, stand noch ne falsche email im Profil drinne.